21 enero 2007

Confesión: paquetes no libres que uso

Me encanta Debian. He probado "unos pocos" sistemas operativos, incluso alguno que el 99% de la gente no sabe ni que existen, y literalmente decenas de distribuciones de Linux, y no cambiaría Debian por ninguno de ellos. Me encanta también la filosofía de su proyecto. Pero, mea culpa, mea massima culpa, no la cumplo a rajatabla.

Y es que en mi sistema tengo paquetes que no son libres. Como penitencia, un repaso rápido de cuales son.
akira@takashi:~$ vrms

Non-free packages installed on takashi

dvdrtools DVD writing program
festvox-ellpc11k Castilian Spanish male speaker for Festival
opensc-dnie SmartCard library with support for Spanish national ID
opera The Opera Web Browser
skype Free Internet Telephony - The whole world can talk for

5 non-free packages, 0.2% of 2370 installed packages.

vrms (Virtual Richard M. Stallman, el nombre lo han clavado) es una pequeña utilidad que te dice qué paquetes no-libres tienes en el sistema. Cinco, un 0.2%. Pues no está mal. Sobre Opera y Skype no hace falta hablar, los conoce todo el mundo. festvox-ellpc11k es la voz en castellano para Festival. En cuanto a opensc-dnie es para la compatibilidad del sistema con el DNI electrónico.

Pero esos no son los únicos. Hay otros, instalados desde otros formatos distintos al DEB:
  • Flash Player. Este no hay más narices que tenerlo, al menos hasta que Gnash esté más maduro.

  • acroread, osea, el Acrobat PDF Reader para Linux. Esto no es por falta de alternativas, pero es que ni KPDF, ni gPDF, ni xPDF me gustan.

  • En el Pentium4 (el portátil tiene gráfica integrada) los drivers de nVIDIA. Espero ansioso unos drivers libres con soporte completo para 3D.

Y ahora mi gran secreto. La vergüenza de las vergüenzas:

Internet Explorer 6 bajo Linux

Sí, "eso" es Internet Explorer 6. En mi Debian. Algo así no tiene perdón, lo sé, pero me gusta saber cómo se ve el blog en los distintos navegadores (nótese el "Listo pero con errores en la página"). La culpa es de IEs4Linux.

En fin, creo que no me dejo nada. Ahí queda mi confesión. ¿Alguien más se atreve?

EDITADO: Parece que kikorb, AwOiSoAk y Jokin también se han "echao p'alante". Como dice el propio Jokin, esto empieza a parecer un meme.

7 comentarios:

kumo dijo...

Pues...

"No Non-free packages installed on KNS-06! rms would be proud"

Eso en el portatil viejo con debian... veamos si en ubuntu tira...

"An invocation of vrms has been added to the set of cron jobs run on a
monthly basis, so that you will get a periodic reminder of non-free
packages which are installed on your system. Here is the current list:

Non-free packages installed on KNS-03

linux-generic Complete Generic Linux kernel
linux-restricted-modules- Non-free Linux 2.6.17 modules on x86_64 generic
linux-restricted-modules- Non-free Linux 2.6.17 modules helper script
linux-restricted-modules- Restricted Linux modules for generic kernels

4 non-free packages, 0.4% of 1060 installed packages."

No esta mal. Aunque se que tambien caigo en los drivers de Nvidia hehe

~aKira~ dijo...

Pues no está nada mal, no. Richard Stallman se sentiría orgulloso, como dice el vrms :)

En cualquier caso, nada tan grave como lo mío :(

kumo dijo...

Bueno, no te fies. El poco tiempo que llevo con linux lo reparto entre Ubuntu y Debian. Y estoy seguro de que Ubuntu es menos fiable en ese aspecto. Por ejemplo los codecs de MP3 y todo eso. (ademas de que me da muchos dolores de cabeza en otros aspectos)

Lo cierto es que algunos drivers, por ejemplo, son mejores en la version propietaria (si no vaya mierda de drivers) y aun son bastante necesarios. Pero todo se andara.

kumo dijo...

Me encuentro con esto en Libertad digital... lo que hay que ver...

http://www.libertaddigital.com/php3/opi_desa.php3?cpn=20570

Puede que stallman sea "demasiado firme" en sus principios. E incluso un tanto extremista, pero vamos, viniendo de esta gente, es casi un halago.

~aKira~ dijo...

Bueno, viniendo de Libertad Digital...
Lo que Antonio José Chinchetru no tiene (o no quiere tener) en cuenta es esto.

Eso suponiendo que lo que dice Chinchetru sea cierto. De hecho, parece ser incluso que nunca ha habido una imposición de Lula a RITS para usar software libre, sino que todo deriva de unas (erróneas) interpretaciones personales en una entrevista a Stallman, que ya fueron aclaradas por éste.

En fin, que Libertad Digital sigue, como siempre, a la suya.

ServoMac dijo...

Por cierto, que es lo que no te gusta de KPDF? Si es el mejor!? :D

~aKira~ dijo...

En cierto modo tienes razón ServoMac: KPDF no tiene nada que envidiar a acroread. Supongo que me expresé mal: es más que nada la p*** costumbre de usar el Acrobat (siete años de Window$ dejaron su huella :(

Cuando empecé a usar GNU/Linux (hace ya cuatro años) no eché en falta nada de Window$, excepto una cosa: el Acrobat, así que en cuanto hubo versión para Linux la instalé, y desde entonces.

Pero aquí y ahora hago propósito de enmienda: voy a dejar de usar acroread y tirarme más por KPDF (gPDF es que ni lo trago)